Main Navigation

Secondary Navigation

Page Contents

Contents

Applications requiring Graphics (OpenGL)

Known Problems for Applications with OpenGL

If you are using a remote desktop connection, please change your configuration to exactly 24 Bit Color.

Some programs require for their graphics OpenGL support which is not always available. Furthermore OpenGL support depends on the login procedure. Below you find a table with some comments and helpers for this issue.
Application Login Wrapper
ssh -X NX X2Go RDP
Abaqus CAE abaqus cae -mesa abaqus cae -mesa jSLURM jSLURM -
ANSYS CFX srun --x11 works with 1) wrapper or jSLURM wrapper or jSLURM rhrk-cfx5
ANSYS Fluent srun --x11 works with 1) wrapper or jSLURM wrapper or jSLURM rhrk-fluent
GaussView srun --x11 works with 1) wrapper or jSLURM wrapper or jSLURM rhrk-gview
ICEM CFD srun --x11 works with 1) wrapper or jSLURM wrapper or jSLURM rhrk-icemcfd
Paraview srun --x11 works with 1) wrapper or jSLURM wrapper or jSLURM rhrk-paraview
1) Set the environment variable LIBGL_ALWAYS_INDIRECT to 1, e.g. with mit "export LIBGL_ALWAYS_INDIRECT=1".